Your requirements could not be resolved to an installable set of packages.
- Root composer.json requires drupal/commerce ^2.30 -> satisfiable by drupal/commerce[2.30.0].
- drupal/commerce 2.30.0 requires drupal/inline_entity_form ^1.0@RC -> found drupal/inline_entity_form[dev-1.x, 1.0.0-alpha1, ..., 1.x-dev (alias of dev-1.x)] but it does not match your minimum-stability.
Installation failed, reverting ./composer.json and ./composer.lock to their original content.
Solved by using following command instead:
1. composer require 'drupal/inline_entity_form:^1.0@RC'
2. composer require 'drupal/commerce'